Appearance
Release notes
Version 1.1.6.3
- Fixed an issue where Queue records remained in Processing state after a timeout (e.g., ECCResponseTimeoutException) instead of transitioning to Error, despite errors being logged.
- Fixed an issue where the Export functionality did not work or not included all related data (such as mappings and mapping lookups) due to encoding issues with special Unicode characters (e.g., ➡), which could cause the export to fail.
- Fixed an issue where the "Escape Special Characters" field was only visible for the Map Field method.
- Fixed an issue where Response Handlers and Error Handling subflows were not triggered when the flow was part of a scoped application, resulting in errors such as "flow object does not exist".
- Fixed an issue where the flow "Retry Failed Queue Record" was executed in the context of the user who triggered it, resulting in insufficient permissions to update Queue records.
- Fixed an issue where blocked update() or insert() operations (e.g., due to Data Policies, Change Models, or Business Rules using setAbortAction) did not throw an exception, causing Queue records to be marked as processed even though the record was not created or updated.
Version 1.1.6.2
- Correction of App version from 1.1.6 to 1.1.6.2
Version 1.1.6.1
- Fixed an issue where the system property binary_file_name was used by both the binary/form-data option and the binary integration option, while it is intended for binary/form-data only.
- Fixed an issue where ACLs on table x_sofbv_sofiehub_m2m_x_sofbv_sofi_sys_use (create, write, delete, read) were not fully aligned with the intended role assignments. The roles sofiehub_admin and sofiehub_integration_user have now been correctly linked.
- Fixed an issue where ACLs on tables x_sofbv_sofiehub_validation_rule and x_sofbv_sofiehub_polling existed but had no roles assigned. The admin and read-only admin roles have now been linked, and for validation rules the integration user role has also been added.
- Added role Integration Logreader, which grants read access to the logging table (x_sofbv_sofiehub_logging) and the queue table (x_sofbv_sofiehub_queue). The relevant SofieHub application menu modules are now also available to users with this role.
- Added role RO Admin (Read-only Admin), which grants read access to all tables related to the SofieHub application. This role allows full visibility of the application data but does not include permissions to create, update, or delete records.
Version 1.1.5
- Added a new feature for web services; validation rules. With validation rules incoming messages can be validated and conditionally be rejected.
- Attachments on queue records will now take the extension of the attachment on the integrated record if not otherwise specified in the x_sofbv_sofiehub.binary_file_name property
- The automatically generated names of mapping records have been updated to be more readable
Version 1.1.4
- Added option to send attachments as binary
- Added feature to add custom form data elements for multipart/form-data attachments
Version 1.1.3
- New feature: ability to prettify JSON in the queue using the system property "x_sofbv_sofiehub.format_json_in_queue"
- Fixed an issue where mappings with "skip if empty = true" did not work correctly on boolean values
- Fixed an issue where retrying a Queue Record did not update the ticket according to the response mapping
- Fixed an issue where the related sysauto_script record for polling did not call the correct script include
- Fixed an issue where incoming messages with no, or an Content-Type other than "application/json" would not be parsed correctly
- Removed the "Pollings" mobile menu item
Version 1.1.2
- New feature: Custom responses on Web Services
- Updated menu structure
- Added missing roles to table
- Fixed a bug in the OpenAPI document generation
- Fixed a bug where lookup tables were not copied when creating a new version of a Web Service
- Fixed various other minor bugs
Version 1.1.1.4
- Bug fix for responses not being returned when record could not be found
Version 1.1.1.3
- Bug fix for failed incoming messages that should not be failing
Version 1.1.1.2
- Attachment not being sent bug fix
Version 1.1.1.1
- Bug fix in outgoing_message
Version 1.1.0
- Web services can now handle array inputs
- Added queryParams as a variable for scripted input mapping
- Ability to use IRE engine on web services
Version 1.0.9.2
- Removed test data
Version 1.0.9.1
- Removed test data
Version 1.0.9
- Feature: Pagination on Provide data
- Feature: Advanced record lookup
- Feature: When multiple actions are defined be able to use the result of the previous action in the following action
- Improvement: Allow for multiple triggers to trigger in a single record update
- Improvement: Remove authorization or other headers containing secrets from the queue
- Bugfix: attachments on (fake) table YY_ZZ caused an error in the system log
- Other: Rebuilt the integration logic to not use flows
Version 1.0.8
- Fixed an issue where fields would be mapped when it shouldn't
- Fixed an issue where incoming attachment would not be mapped with error message 'Attachment has no data or filename' while it should map
- Enhanced the Multipart/form-data binary attachment functionality
- Introduced a new feature to make the ${url.parameter} condition optional
Version 1.0.7.1
- Fixed retry mechanism. Make sure to enable "Retry If Failed" on a "Action"-record to enable the retry mechanism.
- Fixed handling of order of actions.
- Fixed a bug caused by the new GlideJsonPath class.
- New feature: send attachments as multipart/form-data (binary)
Version 1.0.7
- Bug Fix - 'No content' http status code on DELETE method
- Bug Fix - When adding attachments all triggers will be checked (before, after, async)
- Bug Fix - Some JSON paths result in wrong result.
- Bug Fix - Validation of web service name
- Bug Fix - Web Service document generation fixed after bug introduced in v1.0.5
- Improvement - Implemented GlideJsonPath
- Feature - Mandatory fields
- Feature - Web Service versioning
